This document teaches you how to list geometrically processed vector data.

Silinmiş Geometrileri Listelemek
Admin 10.03.2020 Kategori : WEB GIS Education Documents

GISLayer - Filter Processed Data

Changes in vector layers (newly added geometries, modified geometries, deleted geometries) can be queried.

Step 1: Attribute Table 🡪 Operation-> Show Changes>

For this query, go to the 'Show Changes' submenu of the 'Operation' menu in the vector layer attribute table.

Attribute Table -> Operation-> Show Changes

There are 4 options:

  • List Recently Added
  • List Edited
  • List Deleted
  • List Available

Listing All Updates, Created And Deleted Features

2.1. List Recently Added

This option lists new geometries added to the vector layer. The example is shown below.

Here is the first version of a vector layer.

Listing All Updates, Created And Deleted Features

After adding some new geometry to this layer, the 'List Recently Added' option is selected.

Listing All Updates, Created And Deleted Features

Then, only recently added data is listed in the attribute table.

Listing All Updates, Created And Deleted Features

2.2. List Edited

This option lists the changed geometries that already exist in the vector layer. The example is shown below.

Listing All Updates, Created And Deleted Features

After editing some geometries, the 'List Edited' option is selected.

Listing All Updates, Created And Deleted Features

Then, only the edited geometries are listed in the attribute table.

Listing All Updates, Created And Deleted Features

2.3. List Deleted

This option lists deleted geometries that previously existed in the vector layer. The example is shown below.

Initially, all data in the layer and its attribute table appear as follows.

Listing All Updates, Created And Deleted Features

After deleting some geometries, the 'List Deleted' option is selected.

Listing All Updates, Created And Deleted Features

Then, only the deleted geometries are listed in the attribute table.

Listing All Updates, Created And Deleted Features

2.4. List Available

This option lists all existing geometries in the vector layer. The example is shown below.

'List Available' option is selected.

Listing All Updates, Created And Deleted Features

Then, all geometries in the layer are listed.

Listing All Updates, Created And Deleted Features

Benzer Gönderiler

Yeni Bir Vektör Katman Oluşturma
Vektörel Dosya Ekleme
Katman Kutusu Kullanımı
Harita Üzerinde Vektörel ÇIzim Yapma
Harita Üzerinde Özel Geometrik Şekilller Çizimi

Son Yazılar

Create a New Vector Layer
Add Vector Layer Files
Layer Box Usage

3-Layer Box Usage

10.03.2020
Adding WFS Service
Adding WMS Service
Adding XYZ Tile Service
Adding PBF and MVT Vector Tile Service
Usage Basemaps and Adding to Map
Add Ministry Of Environment And Urbanisation Base Maps
Usage TKGM And HGM Basemaps
Vector Drawing On The Map
Drawing Special Geometric Shapes On The Map
Measuring Length And Area On The Map
Getting Information From Vector Feature On The Map
Selecting Vector Feature On The Map
Finding TKGM Parcels On The Map
Setting the Drawing Order of Layers
Adding Previously Used Layers
Displaying The Vector Layer Attribute Data Table
Selections In Attribute Table
Delete Records In Attribute Table
Showing Features Use By Data Attribute Table
Changing Features Color Use By Data Table
Export Attribute Table
Finding Country, City, District And Neighborhood Geometry
Downloading Open Street Map (OSM) Vector Data From The Map
Map Indexing System
Creating Buffers Around Geometries
Clipping Of Geometries Using Overlapping Geometries
Rotate Geometries Around A Specific Anchor
Moving Geometries From One Position To Another
Simplifying Geometries
Smoothing Geometries
Creating The Triangular Terrain Model Using Point Heights
Creating Point, Triangle, And Square Grids Within An Area
Downloading Maps For Offline Use
Get Points From Geometries And Layers
View GeoJson Format Of A Layer
View GeoTiff

39-View GeoTiff

10.03.2020
Add Data With Overpass API
Listing All Updates, Created And Deleted Features
Adding WFS-T Service
Changing Map Color
Raster Color Information
Saving And Displaying System Files
Listing System Files And Adding To The Map
Sharing System File
Displaying Files And People You Share
Displaying, Adding And Deleting My Shared Files
Adding The Shared File To The Map And Stop Sharing
Add, Edit, Delete Geometry In Real-Time
Sending Back System File Changes
Displaying Log File
Making A Map Open To Everyone
Listing Maps Shared With Everyone
Drawing Arc

56-Drawing Arc

10.03.2020
Display Available GISMoney
Sign In

58-Sign In

10.03.2020