Teaches you how to view information about each vector data itself and how to use the table better.

Invert Selection
Admin 10.03.2020 Kategori : WEB GIS Education Documents

Attribute table; the attribute table is used to display common fields of the geometries of a vector layer as table. This feature we have created for you has a stronger processing capacity, unlike many other GIS programs.

There are 2 methods to display the attribute table in GISLayer Software. These are;

  1. You can list the data of all geometries in the layer by clicking the Other Features button, which is located as three points on the far right of the layer whose data you want to list in the Layer Box, and clicking Open Attribute Table in the drop-down list.
  2. When the layer you want to access their attributes is selected, you can simply open the attribute table with the SHIFT + T shortcut

The buttons and their sequence of use are shown in the following screenshot.

Displaying The Vector Layer Attribute Table

Part 1: Introducing the Attribute Table

The attribute table opened by either of the above methods displays the common attributes of the geometries in your vector layer. The opened attribute table can be expanded and contracted in aspect ratio with the green triangle in the lower right corner. The table shows the user the data in the order in which the geometries are inserted.

You can easily perform filterings with quick filter option, which are located under the column names in the table. There are also 6 main menus at the top of the Layer Attribute Table. Additionally, two buttons for each geometry, located at the end of the rows, are described with the numbers 7 and 8. These are;

  1. Selection
  2. Operation
  3. Export
  4. Query
  5. Settings
  6. Calculations
  7. Zoom to Feature
  8. Delete

These menu locations and buttons are shown in the screenshot below.

Displaying The Vector Layer Attribute Table

1. Selection Menu and Sub-Options

Separate selections are made by holding down the CTRL key and clicking with the mouse in the first column of the layer attriubute table, which shows the sequence number of the geometry (CTRL + mouse-left-click). Likewise, the selection is cancelled when the sequence number of the selected geometry is clicked.

If you click on the Selection menu shown above, you will be presented with 6 different options. These are;

  1. Select all: Selects all records in the table.
  2. Clear All Selections: Cancels all existing selections.
  3. Select Filtered: When filtering is complete, the records in the filter result are selected.
  4. Show Selected: Lists only those selected, non-selected will be unvisible in the table.
  5. Switch Selection: Clears selected and selects unselected geometies in the table.
  6. Spatial Selection: Activates the spatial selection within the layer whose attributes are listed, as shown earlier in the Edit menu,
    1. Select by Click
    2. Select Intersections: Select geometries that intersect with a drawn Line
    3. Select Within: Select all geometries within the drawn Polygon

The locations of these tools are shown in the screenshot below.

Displaying The Vector Layer Attribute Table

2. Operation Menu and Sub-Options

There are 4 different options in the Operation Menu. These are;

  1. Delete Record
  2. Show Record
  3. Change Color
  4. Graph All

1-Delete Record: It is used to delete the vector data using table. And It has 3 sub options. These are;

  • Delete All Records: Deletes all the records in the table
  • Delete Selected: Deletes all selected records in the table
  • Delete Filtered: Deletes all filtered records in the table

2-Show Record: It is used to zoom to the records and display them in a different color for a short time. The goal is to make it easier to see records that you want to focus on.

  • Show All: Shows all the records in the table
  • Show Selected: Shows all selected records in the table
  • Show Filtered: Shows all filtered records in the table

3-Change Color: Changing the colors of the records allows you to focus on them more easily on the map. You can even create a thematic look if you wish.

  • Color All: Changes the color of all records in the table
  • Color Selected: Changes the color of all selected records in the table
  • Color Filtered: Changes the color of all filtered records in the table
  • Color to the originall: Restores all records to the original color that the layer originally had.
  • Hide Selected: Hides unselected ones when displaying selected geometries in the table
  • Show Unselected: Hides selected while displaying unselected geometries in the table

4-Graph All: It is used to create graphs for analysis. For example, you can create pie chart, bar chart, line chart, and export these charts. For this purpose;

  • Graph All: You can graph all the records in the table.
  • Graph Selected: You can graph all the selected records in the table.
  • Graph Filtered: You can graph all the filtered records in the table.

These options are shown in the screenshot below.

Displaying The Vector Layer Attribute Table

3. Export Menu and Sub-Options

While the first three options in the Export Menu export your geometric data, the remaining 4 options help you to export the data in the table. These are;

  1. All Records: It is used to export all records in SHP, KML, GeoJSON, WKT, GPX, NCN, Geo Excel formats and EPSG: 4326 Projection system
  2. Selected Records:It is used to export all selected records of the table in SHP, KML, GeoJSON, WKT, GPX, NCN, Geo Excel formats and EPSG: 4326 projection system.
  3. Filtered Records: It is used to export all filtered records in SHP, KML, GeoJSON, WKT, GPX, NCN, Geo Excel formats and EPSG: 4326 Projection system.
  4. Download as Excel: You can download all records in the table as EXCEL
  5. Download as PDF: You can download all records in the table as PDF
  6. Download as JSON: You can download all records in the table as JSON
  7. Download as CSV: You can download all records in the table as CSV

Shown in the screenshot below.

Displaying The Vector Layer Attribute Table

4. Query Menu

Two types of queries can be performed in the query menu. These are;

  1. Attribute Query: Query based on existing information of geometries in table
  2. Spatial Query: Query based on the spatial relation of geometric data with each other.

Shown in the screenshot below.

Displaying The Vector Layer Attribute Table

Settings Menu

Two options are available in the Settings Menu. These are;

  1. Table Column Settings: Lets you edit the columns in the table
  2. Projection Settings: Sets the projection of geometries

It is also shown in the image below.

Displaying The Vector Layer Attribute Table

6.Calculation Menu

There are 2 options in the Calculations Menu. These are;

  1. Column Based Calculations: It allows transactions between the common columns of the listed records, numerical and alfanumerical calculations can be performed according to the data type of the columns. It enables transactions between columns.
  2. Geometric Calculations: It allows to make vector calculations by using the geometric information of the listed data. There are also different operations than field calculation, finding lengths.

It is shown in the image below.

Displaying The Vector Layer Attribute Table

Benzer Gönderiler

Katman Kutusu Kullanımı
Harita Üzerinden Vektörel Verilerin Bilgisini Alma

Son Yazılar

Create a New Vector Layer
Add Vector Layer Files
Layer Box Usage

3-Layer Box Usage

10.03.2020
Adding WFS Service
Adding WMS Service
Adding XYZ Tile Service
Adding PBF and MVT Vector Tile Service
Usage Basemaps and Adding to Map
Add Ministry Of Environment And Urbanisation Base Maps
Usage TKGM And HGM Basemaps
Vector Drawing On The Map
Drawing Special Geometric Shapes On The Map
Measuring Length And Area On The Map
Getting Information From Vector Feature On The Map
Selecting Vector Feature On The Map
Finding TKGM Parcels On The Map
Setting the Drawing Order of Layers
Adding Previously Used Layers
Displaying The Vector Layer Attribute Data Table
Selections In Attribute Table
Delete Records In Attribute Table
Showing Features Use By Data Attribute Table
Changing Features Color Use By Data Table
Export Attribute Table
Finding Country, City, District And Neighborhood Geometry
Downloading Open Street Map (OSM) Vector Data From The Map
Map Indexing System
Creating Buffers Around Geometries
Clipping Of Geometries Using Overlapping Geometries
Rotate Geometries Around A Specific Anchor
Moving Geometries From One Position To Another
Simplifying Geometries
Smoothing Geometries
Creating The Triangular Terrain Model Using Point Heights
Creating Point, Triangle, And Square Grids Within An Area
Downloading Maps For Offline Use
Get Points From Geometries And Layers
View GeoJson Format Of A Layer
View GeoTiff

39-View GeoTiff

10.03.2020
Add Data With Overpass API
Listing All Updates, Created And Deleted Features
Adding WFS-T Service
Changing Map Color
Raster Color Information
Saving And Displaying System Files
Listing System Files And Adding To The Map
Sharing System File
Displaying Files And People You Share
Displaying, Adding And Deleting My Shared Files
Adding The Shared File To The Map And Stop Sharing
Add, Edit, Delete Geometry In Real-Time
Sending Back System File Changes
Displaying Log File
Making A Map Open To Everyone
Listing Maps Shared With Everyone
Drawing Arc

56-Drawing Arc

10.03.2020
Display Available GISMoney
Sign In

58-Sign In

10.03.2020