This document teaches the user the selection options in the attribute tables of the layers.

Admin 10.03.2020 类别 : WEB GIS Education Documents

In GISLayer Software, separate selections are made by holding down the CTRL key and clicking with the mouse in the first column of the layer attriubute table, which shows the sequence number of the geometry (CTRL + mouse-left-click). Likewise, the selection is cancelled when the sequence number of the selected geometry is clicked.

If you click on the Selection menu, you will be presented with 6 different options.

These are;

  1. Select All
  2. Clear All Selections
  3. Select Filtered
  4. Show Selected
  5. Show All
  6. Swich Selection
  7. Spatial Selection

The locations of these tools are shown in the screenshot below.

Selections In Attribute Table

1.Selection: Select All

Select all: Selects all records in the table

An example of the Select All is shown in the screenshot below.

Selections In Attribute Table

2. Clear All Selections

Clear All Selections Cancels all existing selections.

An example of the Clear All Selections is shown in the screenshot below.

Selections In Attribute Table

3. Select Filtered

Select Filtered When filtering is performed; the records are selected in the filter result.

In the image below, a sample example has been made by filtering the "building" and clicking on the Select Filtered option.

Selections In Attribute Table

4. Show Selected

Show Selected: Shows all records selected in the table.

An example of the Show Selected is shown in the screenshot below.

Selections In Attribute Table

5. Show All

Show All option lists all geometries within the layer.

6. Switch Selection

Switch Selection: Clears selection and selects unselected geometies in the table.

For example, if you want to select the selected ones in the list but not the ones selected, the selection can be made by clicking the Swich Selection option. An example has been made for example in the image below.

Selections In Attribute Table

7. Spatial Selection

Spatial Selection: Activates the spatial selection within the layer whose attributes are listed, as shown earlier in the Edit menu,

  1. Select by Click
  2. Select Intersections: Select geometries that intersect with a drawn Line
  3. Select Within: Select all geometries within the drawn Polygon

The scrdeenshot below shows an example these options.

Selections In Attribute Table

相关文件

Selections In Attribute Table
Displaying the Vector Layer Attribute Data Table
Create a New Vector Layer
Add Vector Layer Files

其他文件

Create a New Vector Layer
Add Vector Layer Files
Layer Box Usage

3-Layer Box Usage

10.03.2020
Adding WFS Service
Adding WMS Service
Adding XYZ Tile Service
Adding PBF and MVT Vector Tile Service
Usage Basemaps & Adding to Map
Add Ministry Of Environment & Urbanisation Base Maps
Usage TKGM & HGM Basemaps
Vector Drawing On The Map
Drawing Special Geometric Shapes On The Map
Measuring Length & Area On The Map
Getting Information From Vector Feature On The Map
Selecting Vector Feature On The Map
Finding TKGM Parcels On The Map
Setting the Drawing Order of Layers
Adding Previously Used Layers
Displaying the Vector Layer Attribute Data Table
Selections In Attribute Table
Delete Records In Attribute Table
Showing Features Use By Data Attribute Table
Changing Features Color Use By Data Table
Export Attribute Table
Finding Country, City, District And Neighborhood Geometry
Downloading Open Street Map (OSM) Vector Data From The Map
Map Indexing System
Creating Buffers Around Geometries
Clipping Of Geometries Using Overlapping Geometries
Rotate Geometries Around a Specific Anchor
Moving Geometries From One Position To Another
Simplifying Geometries
Smoothing Geometries
Creating the Triangular Terrain Model Using Point Heights
Creating Point, Triangle, And Square Grids Within an Area
Downloading Maps For Offline Use
Get Points From Geometries and Layers
View GeoJson Format Of a Layer
View GeoTiff

39-View GeoTiff

10.03.2020
Add Data With Overpass API
Listing All Updates, Created & Deleted Features
Adding WFS-T Service
Changing Map Color
Raster Color Information
Saving & Displaying System Files
Listing System Files & Adding To The Map
Sharing System File
Displaying Files & People You Share
Displaying, Adding & Deleting My Shared Files
Adding the Shared File to The Map & Stop Sharing
Add, Edit, Delete Geometry in Real-Time
Sending Back System File Changes
Displaying Log Table
Making a Map Open to Everyone
Listing Maps Shared With Everyone
Drawing Arc

56-Drawing Arc

10.03.2020
Display Available GISMoney
Sign In

58-Sign In

10.03.2020
Adding Raster Files
Remote Sensing Analysis
Getting Printout Map
Spatial Layer Joining
Querying Layer Attributes
Layer Styling

64-Layer Styling

10.03.2020
Creating Analysis Result Chart
Heatmap Density Map Analysis
Thematic Map Analysis
Coordinate Transformation
Creating Isohips Curve